Changes to ABACUS Site Security Settings

ABACUS are continually reviewing our IT security in line with industry best practice to ensure we keep your customers data secure.  As part of this process, ABACUS will be making a change to its website that disables the use of TLS 1.0 security which is used by older internet browsers and replace it with a more up to date version.

What Do You Need to Do?

Users of Internet Explorer versions 8, 9 and 10 will need to make a small change to their settings to ensure they can continue to use the ABACUS website.  Users of up to date versions of Firefox, Chrome, Safari and Internet Explorer 11 are unaffected.

To enable TLS 1.1 and TLS 1.2 in Internet Explorer 8, 9 and 10;

  1. On the Internet Explorer Tools menu, click Internet Options
  2. In the Internet Options dialogue box, click the advanced tab
  3. In the Security category, select the ‘Use TLS 1.1’ and ‘Use TLS 1.2’ checkboxes
  4. Click OK
  5. Exit and Restart Internet Explorer

When Will This Happen?

ABACUS will be making this change on Wednesday 12th July 2017.

Need Help?

If you have trouble accessing the ABACUS site after the above date, call our agency team on 01702 606 312 who will be happy to help.

About the Author Richard Burgess

Richard Burgess is a Director at ABACUS.

follow me on:

Popular posts